Configurar GLPI con active directory en Windows Server 2012

GLPIAC

Unas de las grandes bondades del GLPI es poder conectar el Active Directory a esta aplicacion para asi todos nuestros usuarios del active directory utilicen su mismo usuarios y contraseña en el aplicativo.

Vamos a la practica ya instalado el GLPI y configurado el Activie Directory en Windows Server 2012,  Vamos a la configuracion.

Nos vamos a  configuración –> Identificación –> Directorios LDAP si es la version de GLPI 0.83.7 o Configuración –> Autenticación –> Directorios LDAP si es la version 0.84.4.

En caso de no tener la extencion LDAP del PHP, instalar en caso de Debian o derivados, “sudo apt-get install php5-ldap”.

Damos añadir

exitosa

Seleccionamos luego Directorio Activo, y por defecto ingresa unos parametos.

ldap

Estos son los parámetros a ingresar. En Caso mio el servidor se llama “Comfamiliar.org” y el usuario Administrador se llama: “Administrator”

Nombre: IPS  “Nombre de la Configuracion”
Servidor Por defecto: “Si”
Activo: “Si”
Servidor: “IP del Servidor de Active Directory”
Filtro de Conexion: “(&(objectClass=user)(objectCategory=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))”
Basedn: dc=comfamiliar,dc=org
rootdn (para las conexiones no anónimas):  cn=Administrator,cn=”Carpeta donde se encuentra el usuario”,dc=comfamiliar,dc=org
Contraseña (para las conexiones no anónimas): “Contraseña del Administrator”
Campo de usuario: samaccountname

Con esta configuración básica puedes conectar el Active Directory al GLPI.

ldap1

Por ultimo le damos añadir y automáticamente nos dice:

Elemento añadido correctamente : IPS

Prueba correcta

Para ver todos nuestros usuarios del Active directory nos vamos a Administración–>Usuarios y escogemos la opcion “Enlace LDAP” –> Importación usuarios nuevos. Y damos buscar y nos aparece la lista de usuarios del Active Directory.

ldap2

Las pruebas las realize con WindowsServer 2003, 2008 y 2012 y las versiones de GLPI, 0.83.7,  0.84 y 0.84.4

Espero que sea de ayuda!!

Anuncios

73 comentarios en “Configurar GLPI con active directory en Windows Server 2012

  1. tengo glpi 0.84.4 instalado en win 2008 Std. SP2 y OCS Inventory Ver. 2.1RC1 y me dá este error “La extensión LDAP de su intérprete PHP no está instalada Imposible utilizar LDAP como origen de conexión externa” he editado el archivo PHP.ini y eliminado el “;” de la línea ldap, pero el servicio apache se cae y no reinicia.

    otro problema, intenté instalar el glpi 0.84.4 + OCS inventory Ver. 2.1RC1 en win 2008 R2 y el servicio apache no se instala

    alguna sugerencia para resolver estos problemas, gracias de antemano

      • hola muchas gracias, por la pronta respuesta.

        información solicitada, obtenida del XAMPP for windows
        1.- PHP Version 5.3.8
        2.- System: Windows NT GLPI 6.0 build 6002 (Windows Server 2008 Standard Edition Service Pack 2) i586
        3.- Apache Versión: Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1

        si hay alguna sugerencia, para resolver la falla en las condiciones actuales, muchas gracias por adelantado

        voy a revisar el EasyPhp

  2. Hola Douglas intenta esto:

    Desde C:\xampp\php copiar los siguientes archivos en C:\Windows\ system .

    libeay32.dll
    libsasl.dll
    ssleay32.dll

    y luego buscar y editar C:\xampp\php\ php.ini y descomentar ” extension = php_ldap.dll “alrededor de la línea 965

    Reinicie XAMPP y usted debe ahora tener acceso a las funciones LDAP de PHP.

    Saludos

  3. Pingback: GLPI A extensão LDAP não esta instalado em seu PHP | Bruno Fernando Antognolli

    • Hola Angel, mira de esta forma:

      cn=Administrator,cn=”Carpeta donde se encuentra el usuario”,dc=comfamiliar,dc=org

      Donde “Administrator” –> Usuario Administrador del Dominio
      “Carpeta donde se encuentra” –> Carpeta
      Comfamiliar –> Dominio
      org –> .org
      ——————–

      Tu carpeta de llama Chavo ?

      saludos

  4. bartoc3: no se si servira de algo pero tengo el glpi en el centos 6.5 instalado en un equipo pero en otro equipo de la misma red esta el windows server con activy directory antes tiene que ir una configuracion????

  5. Alguien sabe como sincronizar y actualizar los usuarios del Directorio Activo a GLPI automaticamente, sin necesidad de seguir la ruta usuarios-importar nuevos usuarios, solo con crear una regla.

    Muchas Gracias

  6. Buenas tardes estoy instalando glpi pero quiero saber si cuando un usuario crea una incidencia, esa incidencia se asocia al inventario de pc que tengo por que quiero tener todos los registros de incidencias a los equipos que tengo en el inventario.

    Por favor agradezco si alguien sabe si se puede hacer con glpi

  7. Buenas, lo he intentado de todas las maneras con el nombre del servidor (nombre del servidor, ldad://nombre del servidor, ip del servidor), pero nada siempre me envía el mensaje “Prueba fallida: servidor ldap”, la verdad no se que estoy haciendo mal, he seguido todos los pasos y hasta chequee en el active directory y copié las indicaciones diredtamente desde ahí.

    • El problema debe estar en la cadena que pasas: nombre del servidor (nombre del servidor, ldad://nombre del servidor, ip del servidor)

      Cuales son los parametros que estas pasando. ?

      Saludos

  8. Excelente material, he logrado una Prueba exitosa: Servidor principal, pero cuando importo los usuarios me indica: Sin directorio asociado a una entidad : busqueda imposible. Los usuarios el Administrador del Dominio los tiene varias unidades administrativa, no en Users. Tengo instalado la version 0.85.20 + algunos plugins y ocsinentory, en Debian 7. Deseo poder usar Directorios LDAP, para que toos los usuarios puedan usar GLPI si tener que crearlos. Muchas gracias por sus comentarios y ayuda.

  9. Buen día estoy tratando de configurar el glpi pero me sale prueba fallida, estoy haciendo todos los pasos tal como lo muestra pero me da ese error prueba fallida

    • Hola @Emmanuel, revisa bien la ruta donde se encuentra el super usuario de windows, ya que aveces es el problema.

      Puedes compartir la cadena o un pantallazo de la configuracion.

      Saludos

      • Ya revise todo bien. Incluso cree otro usuario para ver si era problema del usuario administrador. Pero nada no me funciona. También te comento el servidor del Active Directory del dominio es un Servidor Server 2000. Habra algún problema con eso?? Espero tu respuesta

    • Hola bartoc3 buenos dias,

      espero me puedas ayudar, esta es la configuraciuo que tengo:

      Nombre: helpdesk
      Servidor Por defecto: Si
      Activo: Si
      Servidor: ldap://192.168.12.50
      Filtro de Conexion: (&(objectClass=user)(objectCategory=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))
      Basedn: dc=midominio,dc=local
      rootdn (para las conexiones no anónimas): cn=glpi,cn=users,dc=midominio,dc=local
      Contraseña (para las conexiones no anónimas): “aquí puse la contraseña de glpi” que es un usuario administrador enterprice en el active directory
      Campo de usuario: samaccountname

      pero me sigue marcando fallo en en la coneccion, espero me puedas ayudar,

      Saludos

  10. Buenas tardes estimados , he realizado la configuracion y tengo el mismo error que otros an postiado
    prueba contra ad satisfactoria, pero no me sincroniza usuarios alguien me puede ayudar

    • Hola Fernando.

      Como se llama tu servidor? En Basedn: dc=”Nombre del servidor de dominio”,dc=org, y en rootdn (para las conexiones no anónimas): cn=Administrator,cn=”Carpeta donde se encuentra el usuario”,dc=comfamiliar,dc=org si el usuario se encuentra dentro de carpetas toca poner todas las carpetas donde se encuentra.

      fijate si depronto el firware del servidor esta bloqueando el puerto de escucha, Que windows Server estas utilizando?

      Saludos y quedo atento

  11. Hola, después de leer este blog logré importar los usuarios, sin embargo solo me importó el user y contraseña, más no los datos de nombre, apellido, teléfono, mail.

    Se puede reimportar y que habría que hacer para que agregue esta información? Sólo me muestra ahora los usuarios que no importé.

    • Hola Carlos, no se si con las nuevas versiones se lograria realiazar, tocaria hacer la pruebas y mirar.. ya que por lo general siempre importa password y usuario. Voy a realizar unas pruebas y te cuento.

      Saludos

      • Muchas gracias. Quedo atento a tus comentarios. Me interesa poder poblar todos los campos que ya tengo completados en el AD, para no duplicar el trabajo.

        Saludos

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s